Jump to content
  • Announcements

    • Hyperion

      WANTED: ROLEPLAY-ERS   09/04/18

      A new roleplay section has been added to the forum.  Jump back into Naerath in a whole new way!
Hyperion

Not Working

Recommended Posts

I was just logged out of the game (via a "your session has expired" message) while trying to open my mail at my Jade Island Settlement.  The game now gives an error message saying it is "experiencing technical difficulties, please try again" later and will not let me log back in (the furthest I get is the email entry screen).  The time is roughly 3:23pm Central Standard Time.

 

Edit - after waiting a couple minutes, I was back in.  I tried opening my mail and the same thing happened again.  Trying to log in with a different account or clearing the cache does not work any better - I still get the technical difficulties error message.

Edit 2 - After noodling around in a couple other areas, I am pretty sure it is the mail that is triggering this. :)

Share this post


Link to post
Share on other sites

Ok, I believe we fixed it! :)

But please let me know if anything like that happens again!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×